another fix for invalid fd messages
[openwrt-10.03/.git] / Makefile
index e2e467cd8c22b58274ea01715f049a623803a7a7..facebe66b678124cef914d9b2ccc1e220bdab84d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,108 +14,133 @@ RELEASE:=Kamikaze
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+
+all: world
+
+SHELL:=/usr/bin/env bash
+export LC_ALL=C
+export LANG=C
+export TOPDIR=${shell pwd}
 include $(TOPDIR)/include/verbose.mk
+ifeq ($(KBUILD_VERBOSE),99)
+  MAKE:=3>/dev/null $(MAKE)
+endif
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+  OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
 else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
+  REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+  ifneq ($(REV),)
+    OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
+  endif
 endif
 export OPENWRTVERSION
 
-all: world
-
-.pkginfo: FORCE
 ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
+  .pkginfo .config: FORCE
+endif
+
+ifeq ($(FORCE),)
+  .config scripts/config/conf scripts/config/mconf: .prereq-build
+  world: .prereq-packages
+endif
+
+.pkginfo:
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
        done > $@
-endif
+
+pkginfo-clean: FORCE
+       -rm -f .pkginfo .config.in
 
 .config.in: .pkginfo
        @./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
 
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
+.config: ./scripts/config/conf .config.in
+       @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
+       @$< -D .config Config.in &> /dev/null
 
-./scripts/config/mconf: .config.in
+scripts/config/mconf:
        @$(MAKE) -C scripts/config all
 
-./scripts/config/conf: .config.in
+scripts/config/conf:
        @$(MAKE) -C scripts/config conf
 
-config: ./scripts/config/conf FORCE
+config: scripts/config/conf .config.in FORCE
        $< Config.in
 
-defconfig: ./scripts/config/conf FORCE
+config-clean: FORCE
+       $(NO_TRACE_MAKE) -C scripts/config clean
+
+defconfig: scripts/config/conf .config.in FORCE
        touch .config
        $< -D .config Config.in
 
-oldconfig: ./scripts/config/conf FORCE
+oldconfig: scripts/config/conf .config.in FORCE
        $< -o Config.in
 
-menuconfig: ./scripts/config/mconf FORCE
+menuconfig: scripts/config/mconf .config.in FORCE
        $< Config.in
 
-config-clean: FORCE
-       $(NO_TRACE_MAKE) -C scripts/config clean
-
 package/%: .pkginfo FORCE
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
 target/%: .pkginfo FORCE
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
+tools/%: FORCE
+       $(MAKE) -C tools $(patsubst tools/%,%,$@)
+
 toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-.config: ./scripts/config/conf FORCE
-       @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
-       @$< -D .config Config.in &> /dev/null
-
-.prereq: $(TOPDIR)/include/prereq.mk .pkginfo
-       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq.mk prereq 2>/dev/null || { \
+.prereq-build: include/prereq-build.mk
+       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
                echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               rm -rf $(TOPDIR)/tmp; \
                false; \
        }
+       @rm -rf $(TOPDIR)/tmp
        @touch $@
 
-prereq: .prereq FORCE
+.prereq-packages: include/prereq.mk .pkginfo .config
+       @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @rm -rf "$(TOPDIR)/tmp"
+       @touch $@
+       
+prereq: .prereq-build .prereq-packages FORCE
 
 download: .config FORCE
+       $(MAKE) tools/download
        $(MAKE) toolchain/download
        $(MAKE) package/download
        $(MAKE) target/download
 
-ifeq ($(FORCE),)
-world: .prereq
-endif
-
 world: .config FORCE
+       $(MAKE) tools/install
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile
        $(MAKE) package/install
        $(MAKE) target/install
+       $(MAKE) package/index
 
 clean: FORCE
        rm -rf build_* bin
 
 dirclean: clean
-       rm -rf staging_dir_* toolchain_build_*
+       rm -rf staging_dir_* toolchain_build_* tool_build
 
 distclean: dirclean config-clean
-       rm -rf dl .*config* .pkg* .prereq
-
+       rm -rf dl .*config* .pkg* .prereq 
 
 .SILENT: clean dirclean distclean config-clean download world
+FORCE: ;
 .PHONY: FORCE
-FORCE:
+%: ;