another fix for invalid fd messages
[openwrt-10.03/.git] / Makefile
index c2538c204573f3eeb392bb50388884d90a50c190..facebe66b678124cef914d9b2ccc1e220bdab84d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -17,8 +17,14 @@ RELEASE:=Kamikaze
 
 all: world
 
+SHELL:=/usr/bin/env bash
+export LC_ALL=C
+export LANG=C
 export TOPDIR=${shell pwd}
 include $(TOPDIR)/include/verbose.mk
+ifeq ($(KBUILD_VERBOSE),99)
+  MAKE:=3>/dev/null $(MAKE)
+endif
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -44,7 +50,7 @@ endif
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir || echo "ERROR: please fix $${dir}Makefile" >&2; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
        done > $@
 
 pkginfo-clean: FORCE
@@ -132,7 +138,7 @@ dirclean: clean
        rm -rf staging_dir_* toolchain_build_* tool_build
 
 distclean: dirclean config-clean
-       rm -rf dl .*config* .pkg* .prereq
+       rm -rf dl .*config* .pkg* .prereq 
 
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;