another fix for invalid fd messages
[openwrt-10.03/.git] / Makefile
index 26721a3524d6b37599558a9498b7a708a61903d9..facebe66b678124cef914d9b2ccc1e220bdab84d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -18,8 +18,13 @@ RELEASE:=Kamikaze
 all: world
 
 SHELL:=/usr/bin/env bash
+export LC_ALL=C
+export LANG=C
 export TOPDIR=${shell pwd}
 include $(TOPDIR)/include/verbose.mk
+ifeq ($(KBUILD_VERBOSE),99)
+  MAKE:=3>/dev/null $(MAKE)
+endif
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)