clear .host.mk before running prereq checks (rechecks for missing packages like gnu...
[openwrt-10.03/.git] / Makefile
index 62a03387463aed51e47d3c46ccb9d19928d799df..f157b9d3a9fe109d4aeaaf9c46c9ad58a412c9b1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,10 +24,7 @@ export TOPDIR=${shell pwd}
 ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
-ifneq ($(shell tty -s <&3 || echo x),x)
-  IS_TTY=1
-  export IS_TTY
-endif
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 
 include $(TOPDIR)/include/verbose.mk
 
@@ -42,17 +39,17 @@ else
 endif
 export OPENWRTVERSION
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts Makefile),tmp/.pkginfo)
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts include),tmp/.pkginfo)
   tmp/.pkginfo: FORCE
 endif
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts Makefile),tmp/.targetinfo)
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts include),tmp/.targetinfo)
   tmp/.targetinfo: FORCE
 endif
 
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
-  world: tmp/.prereq-packages
+  world: tmp/.prereq-packages tmp/.prereq-target
 endif
 
 tmp/.pkginfo:
@@ -123,6 +120,7 @@ toolchain/%: tmp/.targetinfo FORCE
 
 tmp/.prereq-build: include/prereq-build.mk
        @mkdir -p tmp
+       @rm -f tmp/.host.mk
        @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
                echo "Prerequisite check failed. Use FORCE=1 to override."; \
                false; \
@@ -131,13 +129,23 @@ tmp/.prereq-build: include/prereq-build.mk
 
 tmp/.prereq-packages: include/prereq.mk tmp/.pkginfo .config
        @mkdir -p tmp
+       @rm -f tmp/.host.mk
        @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
                echo "Prerequisite check failed. Use FORCE=1 to override."; \
                false; \
        }
        @touch $@
-       
-prereq: tmp/.prereq-build tmp/.prereq-packages FORCE
+
+tmp/.prereq-target: include/prereq.mk tmp/.targetinfo .config
+       @mkdir -p tmp
+       @rm -f tmp/.host.mk
+       @$(NO_TRACE_MAKE) -s -C target prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+prereq: tmp/.prereq-build tmp/.prereq-packages tmp/.prereq-target FORCE
 
 download: .config FORCE
        $(MAKE) tools/download