move ccache dir to staging_dir_arch (removing the staging dir will make the ccache...
[openwrt-10.03/.git] / Makefile
index b1bcf91a132f8268a5b469521b021bc439c3ccf1..ed1e34db474f93dc62991a476afb813f300d52d6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,20 +1,10 @@
 # Makefile for OpenWrt
 #
+# Copyright (C) 2006 OpenWrt.org
 # Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
 RELEASE:=Kamikaze
@@ -24,67 +14,127 @@ RELEASE:=Kamikaze
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+
+all: world
+
+export TOPDIR=${shell pwd}
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+  OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
 else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
+  REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+  ifneq ($(REV),)
+    OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
+  endif
 endif
 export OPENWRTVERSION
 
-all: world
-
-.pkginfo: FORCE
 ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
+  .pkginfo .config: FORCE
+endif
+
+ifeq ($(FORCE),)
+  .config scripts/config/conf scripts/config/mconf: .prereq-build
+  world: .prereq-packages
+endif
+
+.pkginfo:
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir || echo "ERROR: please fix $${dir}Makefile" >&2; \
        done > $@
-endif
-
-.config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
 
 pkginfo-clean: FORCE
        -rm -f .pkginfo .config.in
 
-scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
+.config.in: .pkginfo
+       @./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
 
-scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
+.config: ./scripts/config/conf .config.in
+       @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
+       @$< -D .config Config.in &> /dev/null
 
-menuconfig: scripts/config/mconf
-       $< Config.in
+scripts/config/mconf:
+       @$(MAKE) -C scripts/config all
 
-config: scripts/config/conf
+scripts/config/conf:
+       @$(MAKE) -C scripts/config conf
+
+config: scripts/config/conf .config.in FORCE
        $< Config.in
 
-config-clean:
-       $(MAKE) -C scripts/config clean
+config-clean: FORCE
+       $(NO_TRACE_MAKE) -C scripts/config clean
+
+defconfig: scripts/config/conf .config.in FORCE
+       touch .config
+       $< -D .config Config.in
+
+oldconfig: scripts/config/conf .config.in FORCE
+       $< -o Config.in
 
-package/%: .pkginfo
+menuconfig: scripts/config/mconf .config.in FORCE
+       $< Config.in
+
+package/%: .pkginfo FORCE
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
-target/%: .pkginfo
+target/%: .pkginfo FORCE
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
-toolchain/%:
+tools/%: FORCE
+       $(MAKE) -C tools $(patsubst tools/%,%,$@)
+
+toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-world:
+.prereq-build: include/prereq-build.mk
+       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               rm -rf $(TOPDIR)/tmp; \
+               false; \
+       }
+       @rm -rf $(TOPDIR)/tmp
+       @touch $@
+
+.prereq-packages: include/prereq.mk .pkginfo .config
+       @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @rm -rf "$(TOPDIR)/tmp"
+       @touch $@
+       
+prereq: .prereq-build .prereq-packages FORCE
+
+download: .config FORCE
+       $(MAKE) tools/download
+       $(MAKE) toolchain/download
+       $(MAKE) package/download
+       $(MAKE) target/download
+
+world: .config FORCE
+       $(MAKE) tools/install
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile
        $(MAKE) package/install
        $(MAKE) target/install
+       $(MAKE) package/index
+
+clean: FORCE
+       rm -rf build_* bin
+
+dirclean: clean
+       rm -rf staging_dir_* toolchain_build_* tool_build
+
+distclean: dirclean config-clean
+       rm -rf dl .*config* .pkg* .prereq 
 
+.SILENT: clean dirclean distclean config-clean download world
+FORCE: ;
 .PHONY: FORCE
-FORCE:
+%: ;