tty detect fix
[openwrt-10.03/.git] / Makefile
index 9b9d1c955e13db4dcdd30951fb87b042a38b2df0..e5e1f6fd3110cd1c7eddde05af84b6da2b9be223 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,20 +1,10 @@
 # Makefile for OpenWrt
 #
+# Copyright (C) 2006 OpenWrt.org
 # Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
 RELEASE:=Kamikaze
@@ -24,51 +14,153 @@ RELEASE:=Kamikaze
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+
+all: world
+
+SHELL:=/usr/bin/env bash
+export LC_ALL=C
+export LANG=C
+export TOPDIR=${shell pwd}
+ifeq ($(KBUILD_VERBOSE),99)
+  MAKE:=3>/dev/null $(MAKE)
+endif
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+  OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
 else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
+  REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+  ifneq ($(REV),)
+    OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
+  endif
 endif
 export OPENWRTVERSION
 
-all:
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts Makefile),tmp/.pkginfo)
+  tmp/.pkginfo: FORCE
+endif
 
-.pkginfo: FORCE
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
+ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts Makefile),tmp/.targetinfo)
+  tmp/.targetinfo: FORCE
+endif
+
+ifeq ($(FORCE),)
+  .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
+  world: tmp/.prereq-packages
+endif
+
+tmp/.pkginfo:
+       @mkdir -p tmp
        @echo Collecting package info...
-       @-for makefile in package/*/Makefile; do \
-               echo Source-Makefile: $$makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -f $$makefile 2>&- || true; \
+       @-for dir in package/*/; do \
+               [ -f "$${dir}/Makefile" ] || continue; \
+               echo Source-Makefile: $${dir}Makefile; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
+               echo; \
+       done > $@
+
+tmp/.targetinfo:
+       @mkdir -p tmp
+       @echo Collecting target info...
+       @-for dir in target/linux/*/; do \
+               [ -f "$${dir}/Makefile" ] || continue; \
+               ( cd "$$dir"; $(NO_TRACE_MAKE) --no-print-dir DUMP=1 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2 ); \
+               echo; \
        done > $@
-endif
 
-.config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
+tmpinfo-clean: FORCE
+       @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
+tmp/.config.in: tmp/.pkginfo
+       @./scripts/gen_package_config.pl < $< > $@ || rm -f $@
 
-scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
+tmp/.config-target.in: tmp/.targetinfo
+       @./scripts/gen_target_config.pl < $< > $@ || rm -f $@
 
-scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
+.config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
+       @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
+       @$< -D .config Config.in &> /dev/null
 
-menuconfig: scripts/config/mconf
+scripts/config/mconf:
+       @$(MAKE) -C scripts/config all
+
+scripts/config/conf:
+       @$(MAKE) -C scripts/config conf
+
+config: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
        $< Config.in
 
-config: scripts/config/conf
+config-clean: FORCE
+       $(NO_TRACE_MAKE) -C scripts/config clean
+
+defconfig: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
+       touch .config
+       $< -D .config Config.in
+
+oldconfig: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
+       $< -o Config.in
+
+menuconfig: scripts/config/mconf tmp/.config.in tmp/.config-target.in FORCE
        $< Config.in
 
-config-clean:
-       $(MAKE) -C scripts/config clean
+package/%: tmp/.pkginfo tmp/.targetinfo FORCE
+       $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%: tmp/.pkginfo tmp/.targetinfo FORCE
+       $(MAKE) -C target $(patsubst target/%,%,$@)
+
+tools/%: FORCE
+       $(MAKE) -C tools $(patsubst tools/%,%,$@)
+
+toolchain/%: tmp/.targetinfo FORCE
+       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+
+tmp/.prereq-build: include/prereq-build.mk
+       @mkdir -p tmp
+       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+tmp/.prereq-packages: include/prereq.mk tmp/.pkginfo .config
+       @mkdir -p tmp
+       @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+       
+prereq: tmp/.prereq-build tmp/.prereq-packages FORCE
+
+download: .config FORCE
+       $(MAKE) tools/download
+       $(MAKE) toolchain/download
+       $(MAKE) package/download
+       $(MAKE) target/download
+
+world: .config FORCE
+       $(MAKE) tools/install
+       $(MAKE) toolchain/install
+       $(MAKE) target/compile
+       $(MAKE) package/compile
+       $(MAKE) package/install
+       $(MAKE) target/install
+       $(MAKE) package/index
+
+clean: FORCE
+       rm -rf build_* bin tmp
+
+dirclean: clean
+       rm -rf staging_dir_* toolchain_build_* tool_build
+
+distclean: dirclean config-clean
+       rm -rf dl
 
+.SILENT: clean dirclean distclean config-clean download world
+FORCE: ;
 .PHONY: FORCE
-FORCE:
+%: ;