fix menuconfig
[openwrt-10.03/.git] / Makefile
index 5b966b752c9dec85fb763ba7213954315f7e4840..d7e4585595c023c96a683f91505d7652abed486d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,93 +14,154 @@ RELEASE:=Kamikaze
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+
+all: world
+
+SHELL:=/usr/bin/env bash
+export LC_ALL=C
+export LANG=C
+export TOPDIR=${CURDIR}
+ifeq ($(KBUILD_VERBOSE),99)
+  MAKE:=3>/dev/null $(MAKE)
+endif
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+
 include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+  OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
 else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
+  REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+  ifneq ($(REV),)
+    OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
+  endif
 endif
 export OPENWRTVERSION
 
-all: world
-
-.pkginfo: FORCE
-ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
-       done > $@
+ifeq ($(FORCE),)
+  .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
+  world: tmp/.prereq-package tmp/.prereq-target
 endif
 
-.config.in: .pkginfo
-       @./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
+package/%/Makefile: ;
+target/%/Makefile: ;
+
+tmp/.packageinfo: $(wildcard package/*/Makefile include/package*.mk include/kernel.mk) 
+tmp/.targetinfo: $(wildcard target/*/Makefile include/kernel*.mk)
+tmp/.%info:
+       @mkdir -p tmp/info
+       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$*info" SCAN_DIR="$(patsubst target,target/linux,$*)" SCAN_NAME="$*" SCAN_DEPS="$^" SCAN_EXTRA=""
+
+tmpinfo-clean: FORCE
+       @-rm -rf tmp/.*info
+
+tmp/.config-%.in: tmp/.%info
+       @./scripts/metadata.pl $*_config < $< > $@ || rm -f $@
+
+
 
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
+.config: ./scripts/config/conf tmp/.config-target.in tmp/.config-package.in
+       @[ -f .config ] || { \
+               [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
+               $(NO_TRACE_MAKE) menuconfig; \
+       }
+       @$< -D .config Config.in &> /dev/null
 
-./scripts/config/mconf: .config.in
+scripts/config/mconf:
        @$(MAKE) -C scripts/config all
 
-./scripts/config/conf: .config.in
+scripts/config/conf:
        @$(MAKE) -C scripts/config conf
 
-config: ./scripts/config/conf FORCE
+
+
+config: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORCE
        $< Config.in
 
-defconfig: ./scripts/config/conf FORCE
+config-clean: FORCE
+       $(NO_TRACE_MAKE) -C scripts/config clean
+
+defconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORCE
        touch .config
        $< -D .config Config.in
 
-oldconfig: ./scripts/config/conf FORCE
+oldconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORCE
        $< -o Config.in
 
-menuconfig: ./scripts/config/mconf FORCE
+menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FORCE
+       @if [ \! -f .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+               cp $(HOME)/.openwrt/defconfig .config; \
+       fi
        $< Config.in
 
-config-clean: FORCE
-       $(MAKE) -C scripts/config clean
+kernel_menuconfig: .config FORCE
+       -$(MAKE) target/linux-prepare
+       $(NO_TRACE_MAKE) -C target/linux menuconfig
 
-package/%: .pkginfo FORCE
-       $(MAKE) -C package $(patsubst package/%,%,$@)
 
-target/%: .pkginfo FORCE
-       $(MAKE) -C target $(patsubst target/%,%,$@)
+package/% target/%: tmp/.packageinfo
+toolchain/% package/% target/%: tmp/.targetinfo
+package/% target/% tools/% toolchain/%: FORCE
+       $(MAKE) -C $(patsubst %/$*,%,$@) $*
 
-toolchain/%: FORCE
-       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-.config: ./scripts/config/conf FORCE
-       @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
-       @$< -D .config Config.in &> /dev/null
+tmp/.prereq-build: include/prereq-build.mk
+       @mkdir -p tmp
+       @rm -f tmp/.host.mk
+       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+tmp/.prereq-%: include/prereq.mk tmp/.%info .config
+       @mkdir -p tmp
+       @rm -f tmp/.host.mk
+       @$(NO_TRACE_MAKE) -s -C $* prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+prereq: tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target FORCE
 
 download: .config FORCE
+       $(MAKE) tools/download
        $(MAKE) toolchain/download
        $(MAKE) package/download
        $(MAKE) target/download
 
 world: .config FORCE
+       $(MAKE) tools/install
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile
        $(MAKE) package/install
        $(MAKE) target/install
+       $(MAKE) package/index
 
 clean: FORCE
-       rm -rf build_* bin
+       rm -rf build_* bin tmp
 
 dirclean: clean
-       rm -rf staging_dir_* toolchain_build_*
+       rm -rf staging_dir_* toolchain_build_* tool_build
+
+distclean: dirclean config-clean symlinkclean docclean
+       rm -rf dl
+
+help:
+       cat README
+
+doc:
+       $(MAKE) -C docs/ openwrt.pdf
+
+docclean:
+       $(MAKE) -C docs/ clean
 
-distclean: dirclean config-clean
-       rm -rf dl .*config* .pkg*
+symlinkclean:
+       find package -type l -exec rm -f {} +
 
-.PHONY: FORCE
-FORCE:
+.SILENT: clean dirclean distclean symlinkclean config-clean download world help
+FORCE: ;
+.PHONY: FORCE help