fix unnecessary rebuild of .targetinfo
[openwrt-10.03/.git] / Makefile
index 57f04359be000d8649677e11b4924f6c59399307..d6b1b7d61854d1118c55e4c08fd52a94353012f1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -38,11 +38,11 @@ endif
 export OPENWRTVERSION
 
 ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts Makefile),tmp/.pkginfo)
-  tmp/.pkginfo: tmpinfo-clean
+  tmp/.pkginfo: FORCE
 endif
 
 ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts Makefile),tmp/.targetinfo)
-  tmp/.targetinfo: tmpinfo-clean
+  tmp/.targetinfo: FORCE
 endif
 
 ifeq ($(FORCE),)
@@ -104,7 +104,7 @@ oldconfig: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
 menuconfig: scripts/config/mconf tmp/.config.in tmp/.config-target.in FORCE
        $< Config.in
 
-package/%: tmp/.pkginfot tmp/.targetinfo FORCE
+package/%: tmp/.pkginfo tmp/.targetinfo FORCE
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
 target/%: tmp/.pkginfo tmp/.targetinfo FORCE