add openwrt image builder to sdk
[openwrt-10.03/.git] / Makefile
index e966188187e9d57eb1f3cc1886157ea0fffa4b24..cd9423314937b2e7ca45a585419b085397c95dc0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -61,8 +61,11 @@ toolchain_install:
 #
 ##############################################################
 
-package_install: toolchain
-       $(MAKE) -C package compile install
+package_compile: target_compile
+       $(MAKE) -C package compile
+
+package_install: package_compile toolchain
+       $(MAKE) -C package install
 
 #############################################################
 #
@@ -91,6 +94,9 @@ package_index:
 target_prepare:
        $(MAKE) -C target prepare
 
+target_compile:
+       $(MAKE) -C target compile
+
 target_install:
        $(MAKE) -C target install