toolchain/ has been converted
[openwrt-10.03/.git] / Makefile
index 8a2e6bbb8e2c90064bdf2f03ca607410091c4b2c..be53622cc18069c9882c8a0515af9f5d3d650258 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,83 +1,48 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
+# Copyright (C) 2007 OpenWrt.org
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
-RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
+all: world
 
-#--------------------------------------------------------------
-# Just run 'make menuconfig', configure stuff, then run 'make'.
-# You shouldn't need to mess with anything beyond this point...
-#--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+TOPDIR:=${CURDIR}
+LC_ALL:=C
+LANG:=C
+IS_TTY:=${shell tty -s && echo 1 || echo 0}
+export TOPDIR LC_ALL LANG IS_TTY
 
-OPENWRTVERSION:=$(RELEASE)
-ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+ifneq ($(OPENWRT_BUILD),1)
+  export OPENWRT_BUILD:=1
+  include $(TOPDIR)/include/toplevel.mk
 else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
-endif
-export OPENWRTVERSION
-
-all:
-
-.pkginfo: FORCE
-ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
-       done > $@
-endif
-
-.config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
-
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
+  include $(TOPDIR)/include/host.mk
 
-scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
+  include rules.mk
+  include $(INCLUDE_DIR)/depends.mk
+  include $(INCLUDE_DIR)/subdir.mk
+  include tools/Makefile
+  include toolchain/Makefile
 
-scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
+clean: FORCE
+       rm -rf build_* bin tmp
 
-menuconfig: scripts/config/mconf
-       $< Config.in
+dirclean: clean
+       rm -rf staging_dir_* toolchain_build_* tool_build
 
-config: scripts/config/conf
-       $< Config.in
+distclean: dirclean config-clean symlinkclean docs/clean
+       rm -rf dl
 
-config-clean:
-       $(MAKE) -C scripts/config clean
+package/% target/%: FORCE
+       $(MAKE) -C $(patsubst %/$*,%,$@) $*
 
-package/%:
-       $(MAKE) -C package $(patsubst package/%,%,$@)
+world: .config $(tools/stamp) $(toolchain/stamp) FORCE
+       $(MAKE) target/compile
+       $(MAKE) package/compile
+       $(MAKE) package/install
+       $(MAKE) target/install
+       $(MAKE) package/index
 
-target/%:
-       $(MAKE) -C target $(patsubst target/%,%,$@)
-
-toolchain/%:
-       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
-
-.PHONY: FORCE
-FORCE:
+endif