fix the jffs2 build for separate 4M/8M images
[openwrt-10.03/.git] / Makefile
index b8c9b10b7068b644538aeaa550fa85cbe49f4e36..ae8e59fbea985782631f16f93a6d7f704e8ef247 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -48,8 +48,7 @@ ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 # along with the packages to build for the target.
 #
 ##############################################################
-TARGETS:=host-sed kernel-headers uclibc-configured binutils gcc uclibc-target-utils
-TARGETS+=openwrt-sstrip linux
+TARGETS:=host-sed kernel-headers uclibc-configured binutils gcc uclibc-target-utils linux openwrt
 
 include toolchain/Makefile.in
 include package/Makefile.in
@@ -83,6 +82,7 @@ TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
 TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
 
 world: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(TARGETS)
+       @echo DONE.
 
 .PHONY: all world clean dirclean distclean source $(TARGETS) \
        $(TARGETS_CLEAN) $(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) \
@@ -118,7 +118,7 @@ $(TARGET_DIR):
        fi;
        -find $(TARGET_DIR) -type d -name CVS | xargs rm -rf
        -find $(TARGET_DIR) -type d -name .svn | xargs rm -rf
-       -ln -sf /tmp/resolv.conf $(TARGET_DIR)
+       -ln -sf /tmp/resolv.conf $(TARGET_DIR)/etc
        -mkdir -p $(TARGET_DIR)/jffs
 
 source: $(TARGETS_SOURCE)
@@ -171,25 +171,21 @@ menuconfig: $(CONFIG)/mconf
        -touch .config
        -cp .config .config.test
        @$(CONFIG)/mconf $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
 
 config: $(CONFIG)/conf
        -touch .config
        -cp .config .config.test
        @$(CONFIG)/conf $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
 
 oldconfig: $(CONFIG)/conf
        -touch .config
        -cp .config .config.test
        @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
 
 randconfig: $(CONFIG)/conf
        -touch .config
        -cp .config .config.test
        @$(CONFIG)/conf -r $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
 
 allyesconfig: $(CONFIG)/conf
        #@$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
@@ -197,19 +193,16 @@ allyesconfig: $(CONFIG)/conf
        -touch .config
        -cp .config .config.test
        @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
 
 allnoconfig: $(CONFIG)/conf
        -touch .config
        -cp .config .config.test
        @$(CONFIG)/conf -n $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
 
 defconfig: $(CONFIG)/conf
        -touch .config
        -cp .config .config.test
        @$(CONFIG)/conf -d $(CONFIG_CONFIG_IN)
-       -./scripts/configtest.pl
 
 #############################################################
 #
@@ -226,3 +219,5 @@ endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 .PHONY: dummy subdirs release distclean clean config oldconfig \
        menuconfig tags check test depend
 
+targets:
+       @echo $(TARGETS)