add support for per-package prereq checks, run global prereq checks before (menu...
[openwrt-10.03/.git] / Makefile
index faeecaa4881e5c7dd2058f5d7ef2b82ba24b2349..a23f478d7cec63b317103f1da84264761a1f4467 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,20 +1,10 @@
 # Makefile for OpenWrt
 #
+# Copyright (C) 2006 OpenWrt.org
 # Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
 RELEASE:=Kamikaze
@@ -26,6 +16,7 @@ RELEASE:=Kamikaze
 #--------------------------------------------------------------
 TOPDIR=${shell pwd}
 export TOPDIR
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -40,26 +31,29 @@ export OPENWRTVERSION
 
 all: world
 
-.pkginfo: FORCE
 ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
+.pkginfo: FORCE
+.config: FORCE
+endif
+
+.pkginfo:
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
        done > $@
-endif
 
 .config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
+       @./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
 
 pkginfo-clean: FORCE
        -rm -f .pkginfo .config.in
 
 ./scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
+       @$(MAKE) -C scripts/config all
 
 ./scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
+       @$(MAKE) -C scripts/config conf
 
 config: ./scripts/config/conf FORCE
        $< Config.in
@@ -75,7 +69,7 @@ menuconfig: ./scripts/config/mconf FORCE
        $< Config.in
 
 config-clean: FORCE
-       $(MAKE) -C scripts/config clean
+       $(NO_TRACE_MAKE) -C scripts/config clean
 
 package/%: .pkginfo FORCE
        $(MAKE) -C package $(patsubst package/%,%,$@)
@@ -86,15 +80,36 @@ target/%: .pkginfo FORCE
 toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-.config: ./scripts/config/conf FORCE
-       @[ -f .config ] || $(MAKE) menuconfig
-       $< -D .config Config.in >/dev/null 2>/dev/null
+.config: ./scripts/config/conf
+       @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
+       @$< -D .config Config.in &> /dev/null
+
+.prereq-build: $(TOPDIR)/include/prereq-build.mk
+       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+.prereq-packages: $(TOPDIR)/include/prereq.mk .pkginfo .config
+       @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+       
+prereq: .prereq-build .prereq-packages FORCE
 
 download: .config FORCE
        $(MAKE) toolchain/download
        $(MAKE) package/download
        $(MAKE) target/download
 
+ifeq ($(FORCE),)
+.config ./scripts/config/conf ./scripts/config/mconf: .prereq-build
+world: .prereq-packages
+endif
+
 world: .config FORCE
        $(MAKE) toolchain/install
        $(MAKE) target/compile
@@ -109,7 +124,9 @@ dirclean: clean
        rm -rf staging_dir_* toolchain_build_*
 
 distclean: dirclean config-clean
-       rm -rf dl .*config* .pkg*
+       rm -rf dl .*config* .pkg* .prereq
+
 
+.SILENT: clean dirclean distclean config-clean download world
 .PHONY: FORCE
 FORCE: