more build system cleanup
[openwrt-10.03/.git] / Makefile
index f93b008033f0f323502c4a73849e489625e46c8c..92b84bb2a748ff07c8d12d9f2a42fa3f32e25b9a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,83 +1,49 @@
 # Makefile for OpenWrt
 #
+# Copyright (C) 2006 OpenWrt.org
 # Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
-RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
+all: world
 
-#--------------------------------------------------------------
-# Just run 'make menuconfig', configure stuff, then run 'make'.
-# You shouldn't need to mess with anything beyond this point...
-#--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
 
-OPENWRTVERSION:=$(RELEASE)
-ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
-else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
-endif
-export OPENWRTVERSION
-
-all:
+TOPDIR:=${CURDIR}
+LC_ALL:=C
+LANG:=C
+IS_TTY:=${shell tty -s && echo 1 || echo 0}
+export TOPDIR LC_ALL LANG IS_TTY
 
-.pkginfo: FORCE
-ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
-       done > $@
-endif
+include rules.mk
 
-.config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
-
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
-
-scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
-
-scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
-
-menuconfig: scripts/config/mconf
-       $< Config.in
+ifneq ($(OPENWRT_BUILD),1)
+  export OPENWRT_BUILD:=1
+  include $(INCLUDE_DIR)/toplevel.mk
+else
+  include $(INCLUDE_DIR)/depends.mk
+  include $(INCLUDE_DIR)/subdir.mk
+  include tools/Makefile
 
-config: scripts/config/conf
-       $< Config.in
+clean: FORCE
+       rm -rf build_* bin tmp
 
-config-clean:
-       $(MAKE) -C scripts/config clean
+dirclean: clean
+       rm -rf staging_dir_* toolchain_build_* tool_build
 
-package/%: .pkginfo
-       $(MAKE) -C package $(patsubst package/%,%,$@)
+distclean: dirclean config-clean symlinkclean docs/clean
+       rm -rf dl
 
-target/%: .pkginfo
-       $(MAKE) -C target $(patsubst target/%,%,$@)
+toolchain/% package/% target/%: FORCE
+       $(MAKE) -C $(patsubst %/$*,%,$@) $*
 
-toolchain/%:
-       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+world: .config $(tools/stamp) FORCE
+       $(MAKE) toolchain/install
+       $(MAKE) target/compile
+       $(MAKE) package/compile
+       $(MAKE) package/install
+       $(MAKE) target/install
+       $(MAKE) package/index
 
-.PHONY: FORCE
-FORCE:
+endif