Show error messages when collecting the package info
[openwrt-10.03/.git] / Makefile
index 32cadb7f991e7455a14684715c00c73a1c9b5777..5b90c482f0a657420986e1eb3d15762af22ba8b6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -44,7 +44,7 @@ endif
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || echo "ERROR: please fix $${dir}Makefile" >&2; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir || echo "ERROR: please fix $${dir}Makefile" >&2; \
        done > $@
 
 pkginfo-clean: FORCE
        done > $@
 
 pkginfo-clean: FORCE