major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / Makefile
index f93b008033f0f323502c4a73849e489625e46c8c..48a138db15e05a6b724d0162b42623d2fd18bdca 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,83 +1,59 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
+# Copyright (C) 2007 OpenWrt.org
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-#
-
-RELEASE:=Kamikaze
-#VERSION:=2.0 # uncomment for final release
-
-#--------------------------------------------------------------
-# Just run 'make menuconfig', configure stuff, then run 'make'.
-# You shouldn't need to mess with anything beyond this point...
-#--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
-
-OPENWRTVERSION:=$(RELEASE)
-ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
-else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
-endif
-export OPENWRTVERSION
-
-all:
 
-.pkginfo: FORCE
-ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
-       done > $@
-endif
+TOPDIR:=${CURDIR}
+LC_ALL:=C
+LANG:=C
+IS_TTY:=${shell tty -s && echo 1 || echo 0}
+export TOPDIR LC_ALL LANG IS_TTY
 
-.config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
+world:
 
-pkginfo-clean: FORCE
-       -rm -f .pkginfo .config.in
+include $(TOPDIR)/include/host.mk
 
-scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
+ifneq ($(OPENWRT_BUILD),1)
+  override OPENWRT_BUILD=1
+  export OPENWRT_BUILD
+  include $(TOPDIR)/include/debug.mk
+  include $(TOPDIR)/include/toplevel.mk
+else
+  include rules.mk
+  include $(INCLUDE_DIR)/depends.mk
+  include $(INCLUDE_DIR)/subdir.mk
+  include target/Makefile
+  include package/Makefile
+  include tools/Makefile
+  include toolchain/Makefile
 
-scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
+$(toolchain/stamp-compile): $(tools/stamp-compile)
+$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
+$(package/stamp-compile): $(target/stamp-compile)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
 
-menuconfig: scripts/config/mconf
-       $< Config.in
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @touch $@
 
-config: scripts/config/conf
-       $< Config.in
+clean: FORCE
+       rm -rf $(BUILD_DIR) $(BIN_DIR)
+       $(MAKE) target/linux/clean
+       rm -rf $(TMP_DIR)
 
-config-clean:
-       $(MAKE) -C scripts/config clean
+dirclean: clean
+       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
 
-package/%: .pkginfo
-       $(MAKE) -C package $(patsubst package/%,%,$@)
+# check prerequisites before starting to build
+prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
-target/%: .pkginfo
-       $(MAKE) -C target $(patsubst target/%,%,$@)
+world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
+       $(MAKE) package/index
 
-toolchain/%:
-       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+package/symlinks:
+       $(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)        
 
-.PHONY: FORCE
-FORCE:
+endif