major target cleanup. it is now possible to have subtargets that can override many...
[openwrt-10.03/.git] / Makefile
index 840c28ff61da0c2ba6fe69cfc270d700f52c9bb8..48a138db15e05a6b724d0162b42623d2fd18bdca 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -14,12 +14,12 @@ export TOPDIR LC_ALL LANG IS_TTY
 
 world:
 
-include $(TOPDIR)/include/debug.mk
 include $(TOPDIR)/include/host.mk
 
 ifneq ($(OPENWRT_BUILD),1)
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
+  include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/toplevel.mk
 else
   include rules.mk
@@ -45,7 +45,7 @@ clean: FORCE
        rm -rf $(TMP_DIR)
 
 dirclean: clean
-       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(BUILD_DIR_TOOLCHAIN) $(BUILD_DIR_HOST)
+       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
 
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;