Add a help target in case people want to read the README ;)
[openwrt-10.03/.git] / Makefile
index f157b9d3a9fe109d4aeaaf9c46c9ad58a412c9b1..2dcb72763613604b738241fd817e1e558f0ac9be 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@ all: world
 SHELL:=/usr/bin/env bash
 export LC_ALL=C
 export LANG=C
-export TOPDIR=${shell pwd}
+export TOPDIR=${CURDIR}
 ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
@@ -171,7 +171,10 @@ dirclean: clean
 distclean: dirclean config-clean
        rm -rf dl
 
+help:
+       cat README
+
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
-.PHONY: FORCE
+.PHONY: FORCE help
 %: ;