clean up console output even more
[openwrt-10.03/.git] / Makefile
index 5b966b752c9dec85fb763ba7213954315f7e4840..27526d09a85b140b65d35f411b1641783af26c89 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -81,11 +81,24 @@ toolchain/%: FORCE
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
        @$< -D .config Config.in &> /dev/null
 
+.prereq: $(TOPDIR)/include/prereq.mk .pkginfo
+       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq.mk prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+prereq: .prereq FORCE
+
 download: .config FORCE
        $(MAKE) toolchain/download
        $(MAKE) package/download
        $(MAKE) target/download
 
+ifeq ($(FORCE),)
+world: .prereq
+endif
+
 world: .config FORCE
        $(MAKE) toolchain/install
        $(MAKE) target/compile
@@ -100,7 +113,9 @@ dirclean: clean
        rm -rf staging_dir_* toolchain_build_*
 
 distclean: dirclean config-clean
-       rm -rf dl .*config* .pkg*
+       rm -rf dl .*config* .pkg* .prereq
+
 
+.SILENT: clean dirclean distclean config-clean download world
 .PHONY: FORCE
 FORCE: