clean up console output even more
[openwrt-10.03/.git] / Makefile
index 1d45582affe7873b4d267d4f54f99701053fbbe8..27526d09a85b140b65d35f411b1641783af26c89 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,20 +1,10 @@
 # Makefile for OpenWrt
 #
+# Copyright (C) 2006 OpenWrt.org
 # Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
 RELEASE:=Kamikaze
@@ -26,6 +16,7 @@ RELEASE:=Kamikaze
 #--------------------------------------------------------------
 TOPDIR=${shell pwd}
 export TOPDIR
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -45,21 +36,21 @@ ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
        done > $@
 endif
 
 .config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
+       @./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
 
 pkginfo-clean: FORCE
        -rm -f .pkginfo .config.in
 
 ./scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
+       @$(MAKE) -C scripts/config all
 
 ./scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
+       @$(MAKE) -C scripts/config conf
 
 config: ./scripts/config/conf FORCE
        $< Config.in
@@ -86,9 +77,29 @@ target/%: .pkginfo FORCE
 toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-world: ./scripts/config/conf FORCE
-       touch .config
-       $< -D .config Config.in >/dev/null 2>/dev/null
+.config: ./scripts/config/conf FORCE
+       @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
+       @$< -D .config Config.in &> /dev/null
+
+.prereq: $(TOPDIR)/include/prereq.mk .pkginfo
+       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq.mk prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+prereq: .prereq FORCE
+
+download: .config FORCE
+       $(MAKE) toolchain/download
+       $(MAKE) package/download
+       $(MAKE) target/download
+
+ifeq ($(FORCE),)
+world: .prereq
+endif
+
+world: .config FORCE
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile
@@ -98,11 +109,13 @@ world: ./scripts/config/conf FORCE
 clean: FORCE
        rm -rf build_* bin
 
-dirclean: clean FORCE
+dirclean: clean
        rm -rf staging_dir_* toolchain_build_*
 
-distclean: dirclean FORCE
-       rm -rf .* dl
+distclean: dirclean config-clean
+       rm -rf dl .*config* .pkg* .prereq
+
 
+.SILENT: clean dirclean distclean config-clean download world
 .PHONY: FORCE
 FORCE: