revert; perl version was entirely too slow
[openwrt-10.03/.git] / Makefile
index b938c241f9f084b77c55e18188dc679751072d66..06288de6b86b1d1ab061080b8f4d5e6177d8e3e6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -38,21 +38,21 @@ endif
 endif
 export OPENWRTVERSION
 
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
-.pkginfo: pkginfo-clean
-endif
+all:
 
-.pkginfo:
+.pkginfo: FORCE
+ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
        @echo Collecting package info...
        @-for makefile in package/*/Makefile; do \
                echo Source-Makefile: $$makefile; \
                $(MAKE) DUMP=1 -f $$makefile 2>&- || true; \
        done > $@
-       
+endif
+
 .config.in: .pkginfo
        ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
 
-pkginfo-clean:
+pkginfo-clean: FORCE
        -rm -f .pkginfo .config.in
 
 scripts/config/mconf: .config.in
@@ -70,6 +70,5 @@ config: scripts/config/conf
 config-clean:
        $(MAKE) -C scripts/config clean
 
-.PHONY: pkginfo-clean
-
-
+.PHONY: FORCE
+FORCE: