move grub to package/
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Oct 2007 03:19:07 +0000 (03:19 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Oct 2007 03:19:07 +0000 (03:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9212 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/grub/Makefile [moved from target/linux/x86/image/grub/Makefile with 88% similarity]
package/grub/menu.lst [moved from target/linux/x86/image/grub/menu.lst with 100% similarity]
package/grub/patches/010-fixes-1.patch [moved from target/linux/x86/image/grub/patches/010-fixes-1.patch with 100% similarity]
target/linux/x86/image/Config.in
target/linux/x86/image/Makefile

similarity index 88%
rename from target/linux/x86/image/grub/Makefile
rename to package/grub/Makefile
index dae74e9dc2ff50707349455f5a799ac945591d83..9fc98173f59c42695593675eb03daa6cbe73a3bd 100644 (file)
@@ -19,9 +19,18 @@ PKG_MD5SUM:=cd3f3eb54446be6003156158d51f4884
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/grub-$(PKG_VERSION)
+PKG_TARGETS:=bin
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/grub
+  SECTION:=boot
+  DEPENDS:=@TARGET_x86
+  CATEGORY:=Boot Loaders
+  TITLE:=GRand Unified Bootloader
+  URL:=http://www.gnu.org/software/grub/
+endef
+
 ifeq ($(HOST_ARCH),x86_64)
 CONFIGURE_FLAGS:= \
        --target=$(GNU_TARGET_NAME) \
@@ -70,4 +79,4 @@ define Build/InstallDev
        mv $(STAGING_DIR_HOST)/usr/sbin/grub $(STAGING_DIR_HOST)/bin
 endef
 
-$(eval $(call Build/DefaultTargets))
+$(eval $(call BuildPackage,grub))
index 4a36f63128b67c0e92ee008b4685bfd4c2a0abcb..17deccfa7243d3910bcdb78be6aed7685116b157 100644 (file)
@@ -2,6 +2,7 @@ config X86_GRUB_IMAGES
     bool "Build GRUB images (Linux x86 or x86_64 host only)"
     depends TARGET_x86
     depends TARGET_ROOTFS_EXT2FS || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS || TARGET_ROOTFS_ISO
+       select PACKAGE_grub
     default y
 
 config X86_GRUB_IMAGES_PAD
index d470fe1c5f6e012f6a5f37029718f096542ccf82..095d40240ba7efc4b9e18693d3dbe6903b01ba82 100644 (file)
@@ -14,14 +14,6 @@ ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
 
 
 ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
-  define Build/Compile
-       $(MAKE) -C grub compile
-  endef
-
-  define Build/Clean
-       $(MAKE) -C grub clean
-  endef
-
   define Image/cmdline/squashfs
     block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
   endef