[hotplug2] Move hotplug2 v0.9 to hotplug2-old
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 May 2009 13:20:54 +0000 (13:20 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 May 2009 13:20:54 +0000 (13:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16135 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hotplug2-old/Makefile [moved from package/hotplug2/Makefile with 81% similarity]
package/hotplug2-old/files/hotplug2.rules [moved from package/hotplug2/files/hotplug2.rules with 100% similarity]
package/hotplug2-old/patches/100-svn_update.patch [moved from package/hotplug2/patches/100-svn_update.patch with 100% similarity]
package/hotplug2-old/patches/110-parser_fixes.patch [moved from package/hotplug2/patches/110-parser_fixes.patch with 100% similarity]
package/hotplug2-old/patches/120-throttling.patch [moved from package/hotplug2/patches/120-throttling.patch with 100% similarity]

similarity index 81%
rename from package/hotplug2/Makefile
rename to package/hotplug2-old/Makefile
index c46da06e0a323c8645c6a224d0deff77ea41422c..a344d5a9096bce50d3eb6ee97e5146886272927d 100644 (file)
@@ -7,17 +7,17 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=hotplug2
+PKG_NAME:=hotplug2-old
 PKG_VERSION:=0.9
 PKG_RELEASE:=3
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=hotplug2-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
 PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/hotplug2
+define Package/hotplug2-old
   SECTION:=base
   CATEGORY:=Base system
   VERSION:=0.9+r102-$(PKG_RELEASE)
@@ -25,18 +25,18 @@ define Package/hotplug2
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
 endef
 
-define Package/hotplug2/description
+define Package/hotplug2-old/description
  Hotplug2 is a trivial replacement of some of the UDev functionality
  in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
 endef
 
 MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES -I."
 
-define Package/hotplug2/install
+define Package/hotplug2-old/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
 endef
 
-$(eval $(call BuildPackage,hotplug2))
+$(eval $(call BuildPackage,hotplug2-old))