move target/utils to tools/firmware-utils
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Dec 2006 23:41:38 +0000 (23:41 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Dec 2006 23:41:38 +0000 (23:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5702 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/Makefile
target/utils/Makefile [deleted file]
tools/Makefile
tools/firmware-utils/Makefile [new file with mode: 0644]
tools/firmware-utils/src/addpattern.c [moved from target/utils/src/addpattern.c with 100% similarity]
tools/firmware-utils/src/dgfirmware.c [moved from target/utils/src/dgfirmware.c with 100% similarity]
tools/firmware-utils/src/motorola-bin.c [moved from target/utils/src/motorola-bin.c with 100% similarity]
tools/firmware-utils/src/trx.c [moved from target/utils/src/trx.c with 100% similarity]
tools/firmware-utils/src/trx2usr.c [moved from target/utils/src/trx2usr.c with 100% similarity]

index d5e6bea01c6a1a470bb953d1b8f8f18179a79531..651c13f6ff91dff08b5e3f7a9e11541a36c78452 100644 (file)
@@ -12,10 +12,9 @@ all: install
 $(BIN_DIR):
        mkdir -p $(BIN_DIR)
 
-TARGETS-y := linux utils
+TARGETS-y := linux
 TARGETS-$(CONFIG_SDK) += sdk
 
-linux-compile: utils-install
 linux-install: $(BIN_DIR)
 image_install: linux-install
 
diff --git a/target/utils/Makefile b/target/utils/Makefile
deleted file mode 100644 (file)
index d11d744..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-TARGETS := addpattern trx motorola-bin dgfirmware trx2usr
-
-UTILS_BUILD_DIR:=$(BUILD_DIR)/target-utils
-
-download:
-prepare: $(UTILS_BUILD_DIR)
-compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS)) FORCE
-       mkdir -p $(STAGING_DIR)/bin
-       $(CP) $(UTILS_BUILD_DIR)/* $(STAGING_DIR)/bin/
-install: compile
-package:
-clean: FORCE
-       rm -rf $(UTILS_BUILD_DIR)
-       for f in $(TARGETS); do \
-               rm -f $(STAGING_DIR)/bin/$$f ; \
-       done
-
-$(UTILS_BUILD_DIR):
-       mkdir -p $(UTILS_BUILD_DIR)
-       
-$(UTILS_BUILD_DIR)/%: src/%.c
-       $(CC) -O2 -I $(STAGING_DIR)/include-host -include endian.h -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
-       chmod 755 $@
-
index eeadde2ed622693f32d30f6f2293ce9bce6bd3b9..f8f08781b5380e23f9d02a681a53ec6f23e64eb1 100644 (file)
@@ -7,7 +7,7 @@
 # Main makefile for the host tools
 #
 include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage
+TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
 
 TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
 TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
new file mode 100644 (file)
index 0000000..7b612ae
--- /dev/null
@@ -0,0 +1,32 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+PKG_NAME := firmware-utils
+PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/firmware-utils
+
+CFLAGS := -O2 -I $(STAGING_DIR)/include-host -include endian.h
+
+define cc
+       $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/bin/$(1) src/$(1).c
+endef
+
+define Build/Compile
+       mkdir -p $(PKG_BUILD_DIR)/bin
+       $(call cc,addpattern)
+       $(call cc,trx)
+       $(call cc,motorola-bin)
+       $(call cc,dgfirmware)
+       $(call cc,trx2usr)
+endef
+
+define Build/Install
+       $(CP) $(PKG_BUILD_DIR)/bin/* $(STAGING_DIR)/bin
+endef
+
+$(eval $(call HostBuild))