at91: create a legacy subtarget
authorFlorian Fainelli <florian@openwrt.org>
Wed, 3 Sep 2014 03:08:51 +0000 (03:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 3 Sep 2014 03:08:51 +0000 (03:08 +0000)
In preparation for adding SAMA5D3 support, move the legacy ARMv5 based
platforms to a separate subtarget.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 42408

target/linux/at91/Makefile
target/linux/at91/legacy/profiles/00-default.mk [moved from target/linux/at91/profiles/00-default.mk with 100% similarity]
target/linux/at91/legacy/profiles/atmel.mk [moved from target/linux/at91/profiles/atmel.mk with 100% similarity]
target/linux/at91/legacy/profiles/calamp.mk [moved from target/linux/at91/profiles/calamp.mk with 100% similarity]
target/linux/at91/legacy/target.mk [new file with mode: 0644]

index 01fc4dd85f9080a4827b1865552218660333a3e7..47fc2f67df23d88f83f3aa21097b1a27d1a205d1 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=at91
 MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs targz ext2 usb
-CPU_TYPE:=arm926ej-s
+SUBTARGETS:=legacy
 
 LINUX_VERSION:=3.10.49
 
diff --git a/target/linux/at91/legacy/target.mk b/target/linux/at91/legacy/target.mk
new file mode 100644 (file)
index 0000000..a3d99bb
--- /dev/null
@@ -0,0 +1,7 @@
+BOARDNAME:=Legacy (ARMv5)
+CPU_TYPE:=arm926ej-s
+
+define Target/Description
+       Build generic firmware for legacy Atmel AT91 platforms
+       using the ARMv5 instruction set.
+endef