ltq-adsl-mei: use the same file name for all variant
authorJonas Gorski <jonas.gorski@gmail.com>
Sat, 4 Nov 2017 11:19:14 +0000 (12:19 +0100)
committerJonas Gorski <jonas.gorski@gmail.com>
Tue, 7 Nov 2017 21:58:58 +0000 (22:58 +0100)
Due to limitations in the symvers treatment and the mei drivers
exporting the same funtions, modpost might use the wrong mei driver
to link against.

Work around this by renaming them all to the same name, making it
always the "right" module name even if the wrong file was used.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
package/kernel/lantiq/ltq-adsl-mei/Makefile
package/kernel/lantiq/ltq-adsl-mei/src/Makefile
package/kernel/lantiq/ltq-adsl-mei/src/drv_mei_cpe.c [moved from package/kernel/lantiq/ltq-adsl-mei/src/lantiq_mei.c with 100% similarity]

index 91c798418d779fc0641a094e706934f5598d5a14..08e5775771d518dcd5102a276056501434a4263f 100644 (file)
@@ -23,8 +23,8 @@ define KernelPackage/ltq-adsl-mei-template
   URL:=http://www.lantiq.com/
   VARIANT:=$(1)
   DEPENDS:=@$(2)
-  FILES:=$(PKG_BUILD_DIR)/ltq_mei_$(1).ko
-  AUTOLOAD:=$(call AutoLoad,50,ltq_mei_$(1))
+  FILES:=$(PKG_BUILD_DIR)/drv_mei_cpe.ko
+  AUTOLOAD:=$(call AutoLoad,50,drv_mei_cpe)
 endef
 
 KernelPackage/ltq-adsl-danube-mei=$(call KernelPackage/ltq-adsl-mei-template,danube,(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy))
index 2d8645f8f273d700d69597d03b7bf2b3f57eae34..9a3b89195c634fe263a55b119fbed5d2cacfe1d5 100644 (file)
@@ -1,17 +1,13 @@
 ifeq ($(BUILD_VARIANT),danube)
   CFLAGS_MODULE = -DCONFIG_DANUBE -DCONFIG_IFXMIPS_DSL_CPE_MEI
-  obj-m = ltq_mei_danube.o
-  ltq_mei_danube-objs = lantiq_mei.o
 endif
 
 ifeq ($(BUILD_VARIANT),ase)
   CFLAGS_MODULE = -DCONFIG_AMAZON_SE -DCONFIG_IFXMIPS_DSL_CPE_MEI
-  obj-m = ltq_mei_ase.o
-  ltq_mei_ase-objs = lantiq_mei.o
 endif
 
 ifeq ($(BUILD_VARIANT),ar9)
   CFLAGS_MODULE = -DCONFIG_AR9 -DCONFIG_IFXMIPS_DSL_CPE_MEI
-  obj-m = ltq_mei_ar9.o
-  ltq_mei_ar9-objs = lantiq_mei.o
 endif
+
+obj-m = drv_mei_cpe.o