Add CRC16 kernel module
authormb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Feb 2009 22:54:11 +0000 (22:54 +0000)
committermb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Feb 2009 22:54:11 +0000 (22:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14548 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index a75195a6bd0205adf86b95a2e5b73850e9e1b014..fb0eb9c6743b93b0c74f8adb37fa4ce710f5ca2d 100644 (file)
@@ -52,6 +52,21 @@ endef
 $(eval $(call KernelPackage,crc7))
 
 
+define KernelPackage/crc16
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=CRC16 support
+  KCONFIG:=CONFIG_CRC16
+  FILES:=$(LINUX_DIR)/lib/crc16.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,20,crc16)
+endef
+
+define KernelPackage/crc16/description
+ Kernel module for CRC16 support
+endef
+
+$(eval $(call KernelPackage,crc16))
+
+
 define KernelPackage/eeprom-93cx6
   SUBMENU:=$(OTHER_MENU)
   TITLE:=EEPROM 93CX6 support