move shfs from target/linux/package/ to package/.
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Jun 2006 09:43:57 +0000 (09:43 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Jun 2006 09:43:57 +0000 (09:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3970 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/shfs/Makefile [moved from target/linux/package/shfs/Makefile with 51% similarity]
package/shfs/patches/101-kmod_build.patch [moved from target/linux/package/shfs/patches/101-kmod_build.patch with 100% similarity]
package/shfs/patches/102-gcc4_fix.patch [moved from target/linux/package/shfs/patches/102-gcc4_fix.patch with 100% similarity]
package/shfs/patches/103-dentry.patch [moved from target/linux/package/shfs/patches/103-dentry.patch with 100% similarity]
target/linux/package/shfs/Config.in [deleted file]
target/linux/package/shfs/ipkg/kmod-shfs.control [deleted file]

similarity index 51%
rename from target/linux/package/shfs/Makefile
rename to package/shfs/Makefile
index 4625bdb12e1c0e703032a710a9ad0dd0eef239c7..dacbf8d75f50e65247782c37ff9df3ba1f9a12c9 100644 (file)
@@ -1,7 +1,7 @@
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include ../../rules.mk
+include $(TOPDIR)/package/kernel.mk
 
 PKG_NAME:=shfs
 PKG_VERSION:=0.35
@@ -17,12 +17,21 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(TOPDIR)/package/rules.mk
 
-$(eval $(call PKG_template,KMOD_SHFS,kmod-shfs,$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))))
-
-$(PKG_BUILD_DIR)/.configured:
-       touch $@
-
-$(PKG_BUILD_DIR)/.built: 
+define Package/kmod-shfs
+ SECTION:=drivers
+ CATEGORY:=Drivers
+ DEPENDS:=
+ TITLE:=Shell FileSystem (ShFS)
+ DESCRIPTION:=Shell FileSystem (ShFS) \\\
+ShFS is a simple and easy to use Linux kernel module which allows you to \\\
+mount remote filesystems using a plain shell (SSH) connection. When using \\\
+ShFS, you can access all remote files just like the local ones, only the \\\
+access is governed through the transport security of SSH.
+ URL:=http://shfs.sourceforge.net/
+ VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+endef
+
+define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -36,11 +45,12 @@ $(PKG_BUILD_DIR)/.built:
                KERNEL_SOURCES="$(LINUX_DIR)" \
                ROOT="$(PKG_INSTALL_DIR)" \
                module module-install
-       touch $@
+endef
 
-$(IPKG_KMOD_SHFS):
-       install -m0755 -d $(IDIR_KMOD_SHFS)/lib/modules/$(LINUX_VERSION)
+define Package/kmod-shfs/install
+       install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
        $(CP) $(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX) \
-        $(IDIR_KMOD_SHFS)/lib/modules/$(LINUX_VERSION)/
-       $(IPKG_BUILD) $(IDIR_KMOD_SHFS) $(PACKAGE_DIR)
+               $(1)/lib/modules/$(LINUX_VERSION)/
+endef
 
+$(eval $(call BuildPackage,kmod-shfs))
diff --git a/target/linux/package/shfs/Config.in b/target/linux/package/shfs/Config.in
deleted file mode 100644 (file)
index 71cc327..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-config PACKAGE_KMOD_SHFS
-       prompt "kmod-shfs......................... Shell FileSystem kernel module (ShFS) kernel module"
-       tristate
-       default m if DEVEL
-       help
-         ShFS is a simple and easy to use Linux kernel module which 
-         allows you to mount remote filesystems using a plain shell 
-         (SSH) connection. When using ShFS, you can access all remote 
-         files just like the local ones, only the access is governed 
-         through the transport security of SSH.
-         
-         ShFS supports some nice features:
-         
-          * file cache for access speedup
-          * perl and shell code for the remote (server) side
-          * could preserve uid/gid (root connection)
-          * number of remote host platforms (Linux, Solaris, Cygwin, ...)
-          * Linux kernel 2.4.10+ and 2.6
-          * arbitrary command used for connection (instead of SSH)
-          * persistent connection (reconnect after SSH dies) 
-         
-         http://shfs.sourceforge.net/
diff --git a/target/linux/package/shfs/ipkg/kmod-shfs.control b/target/linux/package/shfs/ipkg/kmod-shfs.control
deleted file mode 100644 (file)
index 240efe6..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-Package: kmod-shfs
-Priority: optional
-Section: sys
-Description: SHell FileSystem Linux kernel module