separate ath9k debugfs support from ath9k debugging, use the mac80211 debugfs config...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 23 Nov 2009 22:01:45 +0000 (22:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 23 Nov 2009 22:01:45 +0000 (22:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18505 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile
package/mac80211/patches/520-ath9k_debugfs_config.patch [new file with mode: 0644]
package/mac80211/patches/530-ath9k_debugfs_chainmask.patch [moved from package/mac80211/patches/520-ath9k_debugfs_chainmask.patch with 93% similarity]
package/mac80211/patches/540-ath9k_debugfs_regaccess.patch [moved from package/mac80211/patches/530-ath9k_debugfs_regaccess.patch with 94% similarity]

index aef79373d7ef2f66cf4e496a76c07a89221406f7..2da34badac870cdcaa1ca205d1beb28168c22751 100644 (file)
@@ -22,6 +22,9 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
 
 PKG_CONFIG_DEPENDS:= \
        CONFIG_PACKAGE_kmod-mac80211 \
+       CONFIG_PACKAGE_MAC80211_DEBUGFS \
+       CONFIG_PACKAGE_ATH_DEBUG \
+       CONFIG_ATH_USER_REGD \
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -498,8 +501,7 @@ BUILDFLAGS:= \
        $(if $(CONFIG_PCI),-DCONFIG_SSB_SPROM) \
        $(if $(CONFIG_LEDS_TRIGGERS), -DCONFIG_MAC80211_LEDS -DCONFIG_LEDS_TRIGGERS -DCONFIG_B43_LEDS -DCONFIG_B43LEGACY_LEDS -DCONFIG_AR9170_LEDS) \
        -DCONFIG_B43_HWRNG -DCONFIG_B43LEGACY_HWRNG \
-       $(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS),-DCONFIG_MAC80211_DEBUGFS) \
-       $(if $(CONFIG_PACKAGE_ATH9K_DEBUG),-DCONFIG_ATH9K_DEBUG) \
+       $(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS),-DCONFIG_MAC80211_DEBUGFS -DCONFIG_ATH9K_DEBUGFS) \
        $(if $(CONFIG_PACKAGE_ATH_DEBUG),-DCONFIG_ATH_DEBUG) \
        -D__CONFIG_MAC80211_RC_DEFAULT=minstrel \
        $(if $(CONFIG_ATH_USER_REGD),-DATH_USER_REGD=1)
@@ -530,7 +532,7 @@ MAKE_OPTS:= \
        CONFIG_ATH_DEBUG=$(if $(CONFIG_PACKAGE_ATH_DEBUG),y) \
        CONFIG_ATH5K=$(if $(CONFIG_PACKAGE_kmod-ath5k),m) \
        CONFIG_ATH9K=$(if $(CONFIG_PACKAGE_kmod-ath9k),m) \
-       CONFIG_ATH9K_DEBUG=$(if $(CONFIG_PACKAGE_ATH9K_DEBUG),y) \
+       CONFIG_ATH9K_DEBUGFS=$(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS),y) \
        CONFIG_ZD1211RW=$(if $(CONFIG_PACKAGE_kmod-zd1211rw),m) \
        CONFIG_P54_COMMON=$(if $(CONFIG_PACKAGE_kmod-p54-common),m) \
        CONFIG_P54_PCI=$(if $(CONFIG_PACKAGE_kmod-p54-pci),m) \
diff --git a/package/mac80211/patches/520-ath9k_debugfs_config.patch b/package/mac80211/patches/520-ath9k_debugfs_config.patch
new file mode 100644 (file)
index 0000000..0213383
--- /dev/null
@@ -0,0 +1,81 @@
+--- a/drivers/net/wireless/ath/ath9k/Makefile
++++ b/drivers/net/wireless/ath/ath9k/Makefile
+@@ -7,7 +7,7 @@ ath9k-y +=     beacon.o \
+ ath9k-$(CONFIG_PCI) += pci.o
+ ath9k-$(CONFIG_ATHEROS_AR71XX) += ahb.o
+-ath9k-$(CONFIG_ATH9K_DEBUG) += debug.o
++ath9k-$(CONFIG_ATH9K_DEBUGFS) += debug.o
+ obj-$(CONFIG_ATH9K) += ath9k.o
+--- a/drivers/net/wireless/ath/ath9k/ath9k.h
++++ b/drivers/net/wireless/ath/ath9k/ath9k.h
+@@ -483,7 +483,7 @@ struct ath_softc {
+       int beacon_interval;
+-#ifdef CONFIG_ATH9K_DEBUG
++#ifdef CONFIG_ATH9K_DEBUGFS
+       struct ath9k_debug debug;
+ #endif
+       struct ath_beacon_config cur_beacon_conf;
+--- a/drivers/net/wireless/ath/ath9k/debug.c
++++ b/drivers/net/wireless/ath/ath9k/debug.c
+@@ -31,6 +31,8 @@ static int ath9k_debugfs_open(struct ino
+       return 0;
+ }
++#ifdef CONFIG_ATH_DEBUG
++
+ static ssize_t read_file_debug(struct file *file, char __user *user_buf,
+                            size_t count, loff_t *ppos)
+ {
+@@ -71,6 +73,8 @@ static const struct file_operations fops
+       .owner = THIS_MODULE
+ };
++#endif
++
+ static ssize_t read_file_dma(struct file *file, char __user *user_buf,
+                            size_t count, loff_t *ppos)
+ {
+@@ -563,10 +567,12 @@ int ath9k_init_debug(struct ath_hw *ah)
+       if (!sc->debug.debugfs_phy)
+               goto err;
++#ifdef CONFIG_ATH_DEBUG
+       sc->debug.debugfs_debug = debugfs_create_file("debug",
+               S_IRUSR | S_IWUSR, sc->debug.debugfs_phy, sc, &fops_debug);
+       if (!sc->debug.debugfs_debug)
+               goto err;
++#endif
+       sc->debug.debugfs_dma = debugfs_create_file("dma", S_IRUSR,
+                                      sc->debug.debugfs_phy, sc, &fops_dma);
+--- a/drivers/net/wireless/ath/ath9k/debug.h
++++ b/drivers/net/wireless/ath/ath9k/debug.h
+@@ -23,13 +23,13 @@
+ struct ath_txq;
+ struct ath_buf;
+-#ifdef CONFIG_ATH9K_DEBUG
++#ifdef CONFIG_ATH9K_DEBUGFS
+ #define TX_STAT_INC(q, c) sc->debug.stats.txstats[q].c++
+ #else
+ #define TX_STAT_INC(q, c) do { } while (0)
+ #endif
+-#ifdef CONFIG_ATH9K_DEBUG
++#ifdef CONFIG_ATH9K_DEBUGFS
+ /**
+  * struct ath_interrupt_stats - Contains statistics about interrupts
+@@ -186,6 +186,6 @@ static inline void ath_debug_stat_retrie
+ {
+ }
+-#endif /* CONFIG_ATH9K_DEBUG */
++#endif /* CONFIG_ATH9K_DEBUGFS */
+ #endif /* DEBUG_H */
similarity index 93%
rename from package/mac80211/patches/520-ath9k_debugfs_chainmask.patch
rename to package/mac80211/patches/530-ath9k_debugfs_chainmask.patch
index d8ca8dfbfb9b99934ca1c645807eadaf803d531c..a26b4dc8aa7d06cce28104d75012f2c3b957893f 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/net/wireless/ath/ath9k/debug.c
 +++ b/drivers/net/wireless/ath/ath9k/debug.c
-@@ -71,6 +71,90 @@ static const struct file_operations fops
-       .owner = THIS_MODULE
- };
+@@ -75,6 +75,90 @@ static const struct file_operations fops
+ #endif
  
 +static ssize_t read_file_tx_chainmask(struct file *file, char __user *user_buf,
 +                           size_t count, loff_t *ppos)
@@ -91,9 +91,9 @@
  static ssize_t read_file_dma(struct file *file, char __user *user_buf,
                             size_t count, loff_t *ppos)
  {
-@@ -568,6 +652,16 @@ int ath9k_init_debug(struct ath_hw *ah)
-       if (!sc->debug.debugfs_debug)
+@@ -574,6 +658,16 @@ int ath9k_init_debug(struct ath_hw *ah)
                goto err;
+ #endif
  
 +      sc->debug.debugfs_rx_chainmask = debugfs_create_file("rx_chainmask",
 +              S_IRUSR | S_IWUSR, sc->debug.debugfs_phy, sc, &fops_rx_chainmask);
        sc->debug.debugfs_dma = debugfs_create_file("dma", S_IRUSR,
                                       sc->debug.debugfs_phy, sc, &fops_dma);
        if (!sc->debug.debugfs_dma)
-@@ -611,6 +705,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
+@@ -617,6 +711,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
        struct ath_common *common = ath9k_hw_common(ah);
        struct ath_softc *sc = (struct ath_softc *) common->priv;
  
similarity index 94%
rename from package/mac80211/patches/530-ath9k_debugfs_regaccess.patch
rename to package/mac80211/patches/540-ath9k_debugfs_regaccess.patch
index b973dbb2aa755951a22f5bfea0bea95126d42eb0..b927b5513702834ab410d4d497e2f85f7cb3add7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/ath9k/debug.c
 +++ b/drivers/net/wireless/ath/ath9k/debug.c
-@@ -634,6 +634,86 @@ static const struct file_operations fops
+@@ -638,6 +638,86 @@ static const struct file_operations fops
        .owner = THIS_MODULE
  };
  
@@ -87,7 +87,7 @@
  int ath9k_init_debug(struct ath_hw *ah)
  {
        struct ath_common *common = ath9k_hw_common(ah);
-@@ -694,6 +774,17 @@ int ath9k_init_debug(struct ath_hw *ah)
+@@ -700,6 +780,17 @@ int ath9k_init_debug(struct ath_hw *ah)
        if (!sc->debug.debugfs_xmit)
                goto err;
  
        return 0;
  err:
        ath9k_exit_debug(ah);
-@@ -707,6 +798,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
+@@ -713,6 +804,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
  
        debugfs_remove(sc->debug.debugfs_tx_chainmask);
        debugfs_remove(sc->debug.debugfs_rx_chainmask);