Make teql hotplug script run sooner
authorGabor Juhos <juhosg@openwrt.org>
Sun, 2 Dec 2012 13:04:03 +0000 (13:04 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 2 Dec 2012 13:04:03 +0000 (13:04 +0000)
In particular, it wants to run before the ntpclient script. Which may
block for a long time attempting to do DNS lookups for NTP servers. In
my case, that would have *worked* if the new device had been added to
teql first, rather than timing out.

This was effectively causing a huge delay between an interface coming
up, and routing actually starting to work.

Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34442

package/network/utils/iproute2/Makefile
package/network/utils/iproute2/files/15-teql [moved from package/network/utils/iproute2/files/30-teql with 100% similarity]

index 8e89617e1218fcf4b5291d95e3e39dca483020b5..256064e85b6bc9137d124403cb7570832ad54675 100644 (file)
@@ -96,7 +96,7 @@ define Package/tc/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_BIN) ./files/30-teql $(1)/etc/hotplug.d/iface/
+       $(INSTALL_BIN) ./files/15-teql $(1)/etc/hotplug.d/iface/
 endef
 
 define Package/genl/install