* Upgrade Magicbox to 2.6.23
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Jan 2008 21:20:06 +0000 (21:20 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Jan 2008 21:20:06 +0000 (21:20 +0000)
* Rename directories

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10286 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/magicbox/Makefile
target/linux/magicbox/config-default [moved from target/linux/magicbox/config-2.6.22 with 97% similarity]
target/linux/magicbox/files/arch/ppc/platforms/4xx/magicbox.c
target/linux/magicbox/patches/001-magicbox_support.patch [moved from target/linux/magicbox/patches-2.6.22/001-magicbox_support.patch with 100% similarity]
target/linux/magicbox/patches/100-cf_slot.patch [moved from target/linux/magicbox/patches-2.6.22/100-cf_slot.patch with 100% similarity]

index 15f035a82e25c0a846ed801b1a799d2390cee102..b7839b13d67cbccbf011292b6f51ce4c3321350d 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=magicbox
 BOARDNAME:=Magicbox
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs jffs2 pci
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.23.14
 LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
similarity index 97%
rename from target/linux/magicbox/config-2.6.22
rename to target/linux/magicbox/config-default
index 32b33a979211aa36513b032c44dbabce1973111e..895742a4fb8670c490d89316280c853b293adf21 100644 (file)
@@ -37,6 +37,7 @@ CONFIG_CONSISTENT_START=0xff100000
 # CONFIG_CPU_FREQ is not set
 # CONFIG_E200 is not set
 # CONFIG_E500 is not set
+# CONFIG_EDAC is not set
 # CONFIG_EP405 is not set
 # CONFIG_FIRMWARE_EDID is not set
 CONFIG_FS_POSIX_ACL=y
@@ -75,7 +76,7 @@ CONFIG_KERNEL_START=0xc0000000
 CONFIG_LOWMEM_SIZE=0x30000000
 # CONFIG_MACINTOSH_DRIVERS is not set
 CONFIG_MAGICBOX=y
-# CONFIG_MATH_EMULATION is not set
+CONFIG_MATH_EMULATION=y
 CONFIG_MINI_FO=y
 CONFIG_MTD=y
 # CONFIG_MTD_ABSENT is not set
@@ -165,9 +166,11 @@ CONFIG_UART0_TTYS0=y
 # CONFIG_UART0_TTYS1 is not set
 # CONFIG_UNUSED_SYMBOLS is not set
 # CONFIG_USB is not set
+# CONFIG_USER_NS is not set
 # CONFIG_VIA_RHINE is not set
 # CONFIG_WALNUT is not set
 CONFIG_WANT_EARLY_SERIAL=y
 # CONFIG_WINDFARM is not set
 # CONFIG_XILINX_ML300 is not set
 # CONFIG_XILINX_ML403 is not set
+# CONFIG_XILINX_SYSACE is not set
index 18c67ab5f68dfba9250dc6fefee96e1147fdb105..e6df7f6408d34b56516626dd3c3b212c99af0c26 100644 (file)
@@ -23,6 +23,7 @@
 #include <linux/tty.h>
 #include <linux/serial.h>
 #include <linux/serial_core.h>
+#include <linux/serial_8250.h>
 #include <linux/platform_device.h>
 #include <linux/mtd/partitions.h>
 #include <linux/mtd/physmap.h>