/proc needs to be mounted before preinit.arch for failsafe
[openwrt-10.03/.git] / tools / sstrip / Makefile
index dc3ff4f6da5cc8405222c01c955e6c7549240ec9..f978eae2647f333f5df9d3e10fc27a30300d6eca 100644 (file)
@@ -5,14 +5,17 @@
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/host-build.mk
 
+PKG_NAME:=sstrip
 PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/sstrip
 
+include $(INCLUDE_DIR)/host-build.mk
+
 OS:=$(shell uname)
-ifeq ($(OS),Darwin)
+ifeq ($(HOST_OS),Darwin)
   CFLAGS += -I./include
 endif
+CFLAGS += -I $(TOPDIR)/tools/include -include endian.h
 
 define Build/Compile
        $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c