use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt/.git] / tools / e2fsprogs / Makefile
index dc4dc70aee9b4c978687d6c990141be0abbb655e..665ca0dcd42a3ee20ab563792fe0bdc266e27c47 100644 (file)
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=@SF/e2fsprogs
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CFLAGS += $(FPIC)
-HOST_LDFLAGS += -static
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 HOST_CONFIGURE_ARGS += \
        --disable-shared \