fix for the password check (checked the wrong variable)
[openwrt-10.03/.git] / toolchain / libnotimpl / Makefile
index 214f51c5dc77bbdf52ed2a367cd117f5668d7e1a..85156723be8f4c89a79f4973fa59cf49ad49e643 100644 (file)
@@ -6,13 +6,14 @@
 #
 include $(TOPDIR)/rules.mk
 
-PKG_NAME := libnotimpl
-PKG_BUILD_DIR := $(TOOL_BUILD_DIR)/libnotimpl
+PKG_NAME:=libnotimpl
+
+PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/libnotimpl
 
 include $(INCLUDE_DIR)/host-build.mk
 
 define cc
-       PATH="$(TARGET_PATH)" $(TARGET_CC) $(TARGET_CFLAGS) -c src/$(1).c -o $(PKG_BUILD_DIR)/$(1).o
+       $(TARGET_CC) $(TARGET_CFLAGS) -c src/$(1).c -o $(PKG_BUILD_DIR)/$(1).o
 endef
 
 define Build/Prepare
@@ -22,7 +23,7 @@ endef
 
 define Build/Compile
        $(call cc,math)
-       PATH="$(TARGET_PATH)" $(TARGET_CROSS)ar rc $(PKG_BUILD_DIR)/libnotimpl.a $(PKG_BUILD_DIR)/*.o
+       $(TARGET_CROSS)ar rc $(PKG_BUILD_DIR)/libnotimpl.a $(PKG_BUILD_DIR)/*.o
 endef
 
 define Build/Install
@@ -31,9 +32,7 @@ define Build/Install
 endef
 
 define Build/Clean
-       rm -rf \
-               $(STAGING_DIR)/usr/lib/libnotimpl.a \
-               $(PKG_BUILD_DIR)
+       rm -f $(STAGING_DIR)/usr/lib/libnotimpl.a
 endef
 
 $(eval $(call HostBuild))