[package] iptables: fix segfault in xtables_parse_protocol() if an unknown protocol...
[openwrt-10.03/.git] / toolchain / glibc / Makefile
index d014cacdedaf4e5dffa900d22c6300e85c9e886f..229f20649e48c5fb20128b49a43e4ff87c95ade1 100644 (file)
@@ -52,11 +52,13 @@ GLIBC_CONFIGURE:= \
        libc_cv_forced_unwind=yes \
        libc_cv_c_cleanup=yes \
        libc_cv_386_tls=yes \
+       libc_cv_slibdir="/lib" \
        $(HOST_BUILD_DIR)/configure \
                --prefix=/usr \
                --build=$(GNU_HOST_NAME) \
                --host=$(REAL_GNU_TARGET_NAME) \
                --with-headers="$(TOOLCHAIN_DIR)/usr/include" \
+               $(if $(CONFIG_mips64)$(CONFIG_mips64el), --enable-kernel="2.6.0") \
                --disable-debug \
                --disable-profile \
                --enable-add-ons="$(GLIBC_ADD_ONS)" \
@@ -87,7 +89,7 @@ define Host/SetToolchainInfo
        $(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
        $(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.gnu.org/software/libc/,' $(TOOLCHAIN_DIR)/info.mk
        $(SED) 's,^\(LIBC_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
-       $(SED) 's,^\(LIBC_PATCHVER\)=.*,\1=,' $(TOOLCHAIN_DIR)/info.mk
+       $(SED) 's,^\(LIBC_SO_VERSION\)=.*,\1=$(PKG_VERSION),' $(TOOLCHAIN_DIR)/info.mk
 endef
 
 define Stage1/Configure