initial attempt at cleaning up subdirectory handling. tools/Makefile is now being...
[openwrt-10.03/.git] / toolchain / gdb / Makefile
index f5c0bf37253eda00b7f832a45034205b222a4b8a..34dca715a7f647c034eb18c002d80c15f9a21b4e 100644 (file)
@@ -14,7 +14,7 @@ PKG_MD5SUM:=05b928f41fa5b482e49ca2c24762a0ae
 PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/gdb
 PKG_CAT:=bzcat
 
-PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/host-build.mk
 
@@ -40,9 +40,16 @@ define Build/Compile
 endef
 
 define Build/Install
-       install -c $(PKG_BUILD_DIR)/gdb/gdb $(TARGET_CROSS)gdb
-       cd $(STAGING_DIR)/bin && \
-               ln -fs $(TARGET_CROSS)gdb $(GNU_TARGET_NAME)-gdb
+       (cd $(STAGING_DIR)/bin; \
+               install -c $(PKG_BUILD_DIR)/gdb/gdb $(TARGET_CROSS)gdb; \
+               ln -fs $(TARGET_CROSS)gdb $(GNU_TARGET_NAME)-gdb; \
+       );
+endef
+
+define Build/Clean
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(STAGING_DIR)/bin/$(TARGET_CROSS)gdb
+       rm -f $(STAGING_DIR)/bin/$(GNU_TARGET_NAME)-gdb
 endef
 
 $(eval $(call HostBuild))