b43-tools: update to version 019
[openwrt/.git] / toolchain / eglibc / common.mk
index f1e3f304559c151d8c027a2e6aff6c3ddde9daf7..9ef92c6667af0f4e80189e997396638f25de43c6 100644 (file)
@@ -34,6 +34,17 @@ HOST_STAMP_CONFIGURED:=$(CUR_BUILD_DIR)/.configured
 HOST_STAMP_BUILT:=$(CUR_BUILD_DIR)/.built
 HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.eglibc_$(VARIANT)_installed
 
+ifeq ($(ARCH),mips64)
+  ifdef CONFIG_MIPS64_ABI_N64
+    TARGET_CFLAGS += -mabi=64
+  endif
+  ifdef CONFIG_MIPS64_ABI_N32
+    TARGET_CFLAGS += -mabi=n32
+  endif
+  ifdef CONFIG_MIPS64_ABI_O32
+    TARGET_CFLAGS += -mabi=32
+  endif
+endif
 
 EGLIBC_CONFIGURE:= \
        BUILD_CC="$(HOSTCC)" \