Minor change to firstboot, closes #591
[openwrt-10.03/.git] / toolchain / Makefile
index 6481ed0d101e444333e2216baef871cefea4e261..92069acb9850c954169f27c0c559b89c5b8ce02a 100644 (file)
@@ -1,9 +1,16 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # Main makefile for the toolchain
+#
 include $(TOPDIR)/rules.mk
-TARGETS-y:=sed kernel-headers sstrip binutils gcc uClibc ipkg-utils libnotimpl squashfs jffs2 lzma
+TARGETS-y:=sed kernel-headers sstrip binutils gcc uClibc ipkg-utils libnotimpl ext2fs squashfs jffs2 lzma
 TARGETS-$(CONFIG_GDB) += gdb
 
-TARGETS_DOWNLOAD:=$(patsubst %,%-source,$(TARGETS-y))
+TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
 TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
 TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
 
@@ -34,8 +41,8 @@ $(STAGING_DIR):
 $(TOOL_BUILD_DIR):
        @mkdir -p $@
 
-%-source: FORCE
-       $(MAKE) -C $(patsubst %-source,%,$@) source
+%-download: FORCE
+       $(MAKE) -C $(patsubst %-download,%,$@) download
 
 %-prepare: $(TOOLCHAIN_STAMP_DIR) $(STAGING_DIR) $(TOOL_BUILD_DIR) FORCE
        @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \