add monit build depends on openssl (fix #231)
[openwrt-10.03/.git] / target / utils / Makefile
index 97628812876531008438b62e2e59b8118d73e1fd..c08bd1a55dcd1b49cf2623a8b26df4cb7a654ea6 100644 (file)
@@ -1,12 +1,6 @@
 include $(TOPDIR)/rules.mk
 
-TARGETS := addpattern trx
-ifeq ($(BR2_TARGET_BELKIN),y)
-TARGETS += belkin-bin
-endif
-ifeq ($(BR2_TARGET_MOTOROLA),y)
-TARGETS += motorola-bin
-endif
+TARGETS := addpattern trx motorola-bin
 
 UTILS_BUILD_DIR:=$(BUILD_DIR)/target-utils
 
@@ -18,6 +12,9 @@ install: compile
 package:
 clean:
        rm -rf $(UTILS_BUILD_DIR)
+       for f in $(TARGETS); do \
+               rm -f $(STAGING_DIR)/bin/$$f ; \
+       done
 
 $(UTILS_BUILD_DIR):
        mkdir -p $(UTILS_BUILD_DIR)