don't rely on temporary variables in config() as they may get overwritten by config_cb()
[openwrt-10.03/.git] / target / utils / Makefile
index 2a91cbbd59cdce231181184b8dd2193296862491..bcd1e653e42fa8b43c6d6fd4a65aa7176cf8a3e7 100644 (file)
@@ -1,23 +1,21 @@
 include $(TOPDIR)/rules.mk
 
-TARGETS := addpattern trx
-ifeq ($(BR2_TARGET_BELKIN),y)
-TARGETS += belkin-bin
-endif
-ifeq ($(BR2_TARGET_MOTOROLA),y)
-TARGETS += motorola-bin
-endif
+TARGETS := addpattern trx motorola-bin dgfirmware
 
 UTILS_BUILD_DIR:=$(BUILD_DIR)/target-utils
 
+source:
 prepare: $(UTILS_BUILD_DIR)
-compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS))
-install: compile
+compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS)) FORCE
        mkdir -p $(STAGING_DIR)/bin
-       cp -a $(UTILS_BUILD_DIR)/* $(STAGING_DIR)/bin/
+       $(CP) $(UTILS_BUILD_DIR)/* $(STAGING_DIR)/bin/
+install: compile
 package:
-clean:
+clean: FORCE
        rm -rf $(UTILS_BUILD_DIR)
+       for f in $(TARGETS); do \
+               rm -f $(STAGING_DIR)/bin/$$f ; \
+       done
 
 $(UTILS_BUILD_DIR):
        mkdir -p $(UTILS_BUILD_DIR)