merge over commit 21412 ("sound-soc-qi_lb60: rename package as underscores are not...
[openwrt-10.03/.git] / target / linux / xburst / image / Makefile
index 0947db0549a7e5224a8b8455d556cd33a57af89f..c445494c7449188cd92f4c02053d7b224821bb15 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
 
 JFFS2_BLOCKSIZE=256k 512k
 
-ifneq ($(CONFIG_TARGET_QI_LB60),)
+ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
 UBIFS_OPTS = -m 4096 -e 516096 -c 4095
 UBINIZE_OPTS = -m 4096 -p 512KiB
 else
@@ -17,18 +17,8 @@ UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
 UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
 endif
 
-ifneq ($(CONFIG_XBURST_UBOOT),)
-  define Build/Clean
-       $(MAKE) -C u-boot clean
-  endef
-
-  define Build/Compile
-       $(MAKE) -C u-boot compile
-  endef
-endif
-
 define Image/BuildKernel
-       cp $(KDIR)/linux-$(LINUX_VERSION)/arch/mips/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage.bin
+       cp $(LINUX_DIR)/arch/mips/boot/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage.bin
 endef
 
 define Image/Build/squashfs
@@ -36,7 +26,7 @@ define Image/Build/squashfs
 endef
 
 define Image/Build
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(SUBTARGET)-root.$(1) bs=128k conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
 endef
 
 $(eval $(call BuildImage))