[xburst] Fix image generation for qi_lb60 subtarget
[openwrt-10.03/.git] / target / linux / xburst / image / Makefile
index 0947db0549a7e5224a8b8455d556cd33a57af89f..199ba2b7d4eb720c86decb92f2807673789c6f5a 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
 
 JFFS2_BLOCKSIZE=256k 512k
 
-ifneq ($(CONFIG_TARGET_QI_LB60),)
+ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
 UBIFS_OPTS = -m 4096 -e 516096 -c 4095
 UBINIZE_OPTS = -m 4096 -p 512KiB
 else
@@ -17,16 +17,6 @@ UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
 UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
 endif
 
-ifneq ($(CONFIG_XBURST_UBOOT),)
-  define Build/Clean
-       $(MAKE) -C u-boot clean
-  endef
-
-  define Build/Compile
-       $(MAKE) -C u-boot compile
-  endef
-endif
-
 define Image/BuildKernel
        cp $(KDIR)/linux-$(LINUX_VERSION)/arch/mips/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage.bin
 endef