[s3c24xx] bump to 2.6.30-rc6
[openwrt-10.03/.git] / target / linux / s3c24xx / image / Makefile
index 9aa3fd389a0b32f37bdff70e9a8ad59623d1a814..2759dcc49409243ffc697262a1c8492431dc0c00 100755 (executable)
@@ -4,19 +4,19 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-#JFFS2_BLOCKSIZE=16k
-#JFFS2OPTS += -n --faketime -x lzo 
-JFFS2OPTS += --little-endian --eraseblock=0x20000 --pagesize=0x800 --no-cleanmarkers --pad -n 
+JFFS2_BLOCKSIZE=128k
+JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
 MAKE += -j5
 
 #:mkfs.jffs2 -x lzo --root=/data/moko/build/tmp/rootfs --faketime --output=/data/moko/build/tmp/deploy/glibc/images/fic-gta01/OpenMoko-openmoko-devel-image-glibc-P1-August-Snapshot-20070829-fic-gta01.rootfs.jffs2 --little-endian --eraseblock=0x4000 --pad -n
 
 
 define Image/BuildKernel
-       $(TARGET_CROSS)objcopy -O binary -R .note -R .comment -S $(KDIR)/linux-2.6.26/arch/arm/boot/compressed/vmlinux linux.bin
+       $(TARGET_CROSS)objcopy -O binary -R .note -R .comment -S $(LINUX_DIR)/arch/arm/boot/compressed/vmlinux linux.bin
        mkimage -A arm -O linux -T kernel -C none -a 30008000 -e 30008000 -n "Openmoko Kernel Image Freerunner (Neo1973(GTA02))" -d linux.bin uImage
 
        cp uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage