add support for target 3c24xx (more known as Openmoko GTA02 "Freerunner") and merge...
[openwrt-10.03/.git] / target / linux / s3c24xx / image / Makefile
diff --git a/target/linux/s3c24xx/image/Makefile b/target/linux/s3c24xx/image/Makefile
new file mode 100755 (executable)
index 0000000..9aa3fd3
--- /dev/null
@@ -0,0 +1,35 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+#JFFS2_BLOCKSIZE=16k
+#JFFS2OPTS += -n --faketime -x lzo 
+JFFS2OPTS += --little-endian --eraseblock=0x20000 --pagesize=0x800 --no-cleanmarkers --pad -n 
+MAKE += -j5
+
+#:mkfs.jffs2 -x lzo --root=/data/moko/build/tmp/rootfs --faketime --output=/data/moko/build/tmp/deploy/glibc/images/fic-gta01/OpenMoko-openmoko-devel-image-glibc-P1-August-Snapshot-20070829-fic-gta01.rootfs.jffs2 --little-endian --eraseblock=0x4000 --pad -n
+
+
+define Image/BuildKernel
+       $(TARGET_CROSS)objcopy -O binary -R .note -R .comment -S $(KDIR)/linux-2.6.26/arch/arm/boot/compressed/vmlinux linux.bin
+       mkimage -A arm -O linux -T kernel -C none -a 30008000 -e 30008000 -n "Openmoko Kernel Image Freerunner (Neo1973(GTA02))" -d linux.bin uImage
+
+       cp uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+endef
+
+define Image/Build/squashfs
+    $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-root.$(1))
+endef
+
+define Image/Build
+       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-root.$(1)
+       $(call Image/Build/$(1),$(1))
+endef
+
+
+$(eval $(call BuildImage))