[kernel] update to 2.6.30.6, compile tested on some targets only
[openwrt-10.03/.git] / target / linux / s3c24xx / Makefile
index 33c7a55480522a388378ccd3c0f6b70e9e19f5ea..03eb5c1c93f229458435f670058ee05ce150421a 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,10 +8,11 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=s3c24xx
-BOARDNAME:=s3c24xx
+BOARDNAME:=Samsung S3C24xx
 FEATURES:=jffs2
+CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
 
-LINUX_VERSION:=2.6.28.7
+LINUX_VERSION:=2.6.30.6
 
 DEVICE_TYPE=phone
 
@@ -19,12 +20,6 @@ define Target/Description
        OpenMoko gta02
 endef
 
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
-
 include $(INCLUDE_DIR)/target.mk
 
 $(eval $(call BuildTarget))