small image builder change
[openwrt-10.03/.git] / target / linux / rules.mk
index 39afadb34188e21b5a07b540f0ac1f7757909a42..606efb6d9ec811916fd611f50eb42fb43b46eb43 100644 (file)
@@ -1,3 +1,10 @@
+LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+       -e 's/mipsel/mips/' \
+       -e 's/powerpc/ppc/' \
+       -e 's/sh[234]/sh/' \
+)
+
+
 define KMOD_template
 ifeq ($$(strip $(4)),)
 KDEPEND_$(1):=m
@@ -39,3 +46,5 @@ endif
        $(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR)
 
 endef
+
+