Update ralink module package in the WiFi profile
[openwrt-10.03/.git] / target / linux / rdc-2.6 / Makefile
index 323eb2c3f4103b8cfc2e6af7356d1db94a166084..12696766113719c475f985ce80503de4c842d0ce 100644 (file)
@@ -6,9 +6,26 @@
 #
 include $(TOPDIR)/rules.mk
 
+ARCH:=i386
+BOARD:=rdc
+BOARDNAME:=RDC x86
+FEATURES:=broken jffs2
+
+define Target/Description
+        Build firmware images for RDC3211 based routers
+        (e.g. Airlink101 AR525W)
+endef
+
 LINUX_VERSION:=2.6.17
 LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+define Profile/Ralink
+  NAME:=Ralink WiFi (default)
+  PACKAGES:=kmod-rt61
+endef
+$(eval $(call Profile,Ralink))
+
 $(eval $(call BuildKernel))