strip the kernel version suffix from target directories, except for brcm-2.4 (the...
[openwrt-10.03/.git] / target / linux / rdc / patches / 002-r6040_ethernet.patch
diff --git a/target/linux/rdc/patches/002-r6040_ethernet.patch b/target/linux/rdc/patches/002-r6040_ethernet.patch
new file mode 100644 (file)
index 0000000..1b93025
--- /dev/null
@@ -0,0 +1,39 @@
+diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
+--- linux-2.6.17/drivers/net/Kconfig   2006-06-18 03:49:35.000000000 +0200
++++ linux-2.6.17.new/drivers/net/Kconfig       2006-09-25 13:14:27.000000000 +0200
+@@ -1358,6 +1358,24 @@
+         <file:Documentation/networking/net-modules.txt>.  The module will be
+         called apricot.
++config R6040
++      tristate "RDC Fast-Ethernet support (EXPERIMENTAL)"
++      depends on NET_PCI && EXPERIMENTAL
++      select MII
++      help
++        If you have a network (Ethernet) controller of this type, say Y and
++        read the Ethernet-HOWTO, available from
++          <http://www.tldp.org/docs.html#howto>.
++
++          To compile this driver as a module, choose M here and read
++          <file:Documentation/networking/net-modules.txt>.  The module will be
++          called r6040.
++
++
++config R6040_NAPI
++      bool "NAPI support for R6040"
++      depends on R6040
++      default y
+ config B44
+       tristate "Broadcom 4400 ethernet support (EXPERIMENTAL)"
+       depends on NET_PCI && PCI && EXPERIMENTAL
+diff -urN linux-2.6.17/drivers/net/Makefile linux-2.6.17.new/drivers/net/Makefile
+--- linux-2.6.17/drivers/net/Makefile  2006-06-18 03:49:35.000000000 +0200
++++ linux-2.6.17.new/drivers/net/Makefile      2006-09-25 13:14:45.000000000 +0200
+@@ -106,6 +106,7 @@
+ obj-$(CONFIG_NE3210) += ne3210.o 8390.o
+ obj-$(CONFIG_NET_SB1250_MAC) += sb1250-mac.o
+ obj-$(CONFIG_B44) += b44.o
++obj-$(CONFIG_R6040) += r6040.o
+ obj-$(CONFIG_FORCEDETH) += forcedeth.o
+ obj-$(CONFIG_NE_H8300) += ne-h8300.o 8390.o