Put back 2.6.24 files as well
[openwrt-10.03/.git] / target / linux / rdc / image / Makefile
index 4d8c5fda339d064a312a2456ae09b9c946818766..4da96b7e18474f5c1940d15fb90246cc55a89734 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/Prepare
-       $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
+       $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
 endef
 
 define trxalign/jffs2-128k
@@ -23,10 +23,12 @@ endef
 
 define Image/Build/ar525w
        touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+       touch $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2)-web.img
        mv $(KDIR)/root.$(1) $(KDIR)/root.tmp
        dd of=$(KDIR)/root.$(1) if=$(KDIR)/root.tmp $(call trxalign/$(1)) conv=sync
        $(RM) $(KDIR)/root.tmp
        $(STAGING_DIR_HOST)/bin/airlink -b 1 -j $(shell bash -c 'echo $$[$(3)]') $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2).img
+       $(STAGING_DIR_HOST)/bin/airlink -e -b 1 -j $(shell bash -c 'echo $$[$(3)]') $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1)-$(2)-web.img
 endef
 
 define Image/Build/wl153