[ar71xx] ag71xx: add initial message level support
[openwrt-10.03/.git] / target / linux / rdc / Makefile
index 1b70c1876fca54aa54d48ca9241f289c332fce55..d56bac010720a587f993295d6032c5a41d247bac 100644 (file)
@@ -8,10 +8,10 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=i386
 BOARD:=rdc
-BOARDNAME:=RDC321x x86
+BOARDNAME:=RDC 321x
 FEATURES:=squashfs jffs2 pci
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -20,16 +20,4 @@ define Target/Description
         (e.g. Airlink101 AR525W, Linksys WRT54R, Sitecom WL-153)
 endef
 
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-  define Kernel/SetInitramfs
-       echo "r6040 parent=wlan0" > $(TARGET_DIR)/etc/modules.d/99-r6040
-       $(RM) $(TARGET_DIR)/sbin/init
-       ln -s /etc/preinit $(TARGET_DIR)/sbin/init
-       sed -i 's,exec /sbin/init,exec /bin/busybox init,g' $(TARGET_DIR)/etc/preinit
-       sed -i 's,/sbin/init,/bin/busybox init,g' $(TARGET_DIR)/init
-       mv $(TARGET_DIR)/init $(TARGET_DIR)/linuxrc
-       sed -i 's,eth0,eth1,g' $(TARGET_DIR)/etc/config/network
-  endef
-endif
-
 $(eval $(call BuildTarget))