[backfire] backport r28376
[openwrt-10.03/.git] / target / linux / rdc / Makefile
index c4bfd66c04165d92a66b47807a102c8d36aedaae..273b65b84bf2e6ffc34fc07c8fac797c627278ee 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,14 +10,14 @@ ARCH:=i386
 BOARD:=rdc
 BOARDNAME:=RDC 321x
 FEATURES:=squashfs jffs2 pci usb pcmcia
-CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
-SUBTARGETS:=amit ar525w r8610 dir-450
+CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-rdc321x-wdt kmod-r6040
+DEFAULT_PACKAGES += wpad-mini kmod-r6040 kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
 
 define Target/Description
         Build firmware images for RDC321x based routers
@@ -25,7 +25,3 @@ define Target/Description
 endef
 
 $(eval $(call BuildTarget))
-
-$(eval $(call RequireCommand,lzma, \
-        Please install lzma-4.4x. \
-))